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Chapter 1 

Introduction to Styles 

 

Session Objectives 

The students will be able to: 

 Classify style categories. 
 Demonstrate styles and formatting. 
 Explain fill format. 
 Perform creating and updating a new style. 
 Discuss updating a style. 
 Describe load styles (from a template or document). 

 Demonstrate applying styles. 
 

 Introduction  

Libre Office Writer offers a variety of features and commands that enable you to create 

an attractive and presentable document with a consistent format. Further, such 

documents are easy to read, comprehend and edit by one and all. In this Unit, you will 

learn to format a document using styles. You will be able to style a document by using 

– Style Formats, create new styles, update styles, apply styles and also to use template 

of other document to format current document. 

         

Introduction to Styles 

A Style is nothing but a collection of all formatting information, which you want to 

save and then apply on the document. For example, following details of Font can be 

stored as a Style by the name title style. 

• Size – 12 
• Name – Bookman Old Style 
• Weight – bold 
• Alignment – Left 

Now we can use and consistently apply title style to all titles of the document. To 

change the style of Title in document, you just need to update the title style and apply 

it in the document. 
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Style Categories 

Writer provides six Style categories, which are as follows: 

Page – All documents in Writer are based on pages, hence for formatting them, Page 

Style is used. It defines basic page layout like page size, its margin, placement of 

header and footer, foot note, borders and background. Writer uses its built in Default 

page style. 

Paragraph – After deciding on page format, next to be worked on in the document is 

content, which is organized in paragraphs. A paragraph begins and ends when you 

press Enter key. Paragraph formatting include tab stops, text alignment, line spacing 

and borders. Usually it also includes Character styling attributes. 

Character – This styling is used to work on block of letters i.e. words in the paragraph 

instead of the whole paragraph. By using character styles, you can change appearance 

of a part of a paragraph without affecting the other part. Character Styles allows 

changing text color, text size, highlighting text, emphasizing it. 

Frame – Using frames, a document can be organized in sections, so that each section 

of the page can have different appearance. Frames are like containers which can hold 

text, graphics and lists. Therefore, applying Frame Styles allows to format a frame by 

specifying its size, position, border, how text is placed around picture. 

List – To style lists in a document, Writer provides a separate category. It can be used 

to style lists by putting numbering or bullets of different kind, specify numeric format.  

Table – Using tables, large amount of information can be organized and presented 

effectively. Table Style category allows to format a table by adding borders, using 

different text or border colors, aligning text inside the table, having different patterns 

or text color. 

Styles and Formatting  

Formatting toolbar, can also be applied using Style menu. In this section, we will learn 

how to format a document using Style feature. There are many predefined Styles in 

Writer, which can be accessed by using following methods: 

• Using Style option from Menu Bar. 

• Using Style Drop Down list box, as shown in Figure 1.1, from the Tool bar. At any          

point of time, current paragraph style is displayed in the text box. 

• Using Sidebar Menu. On the Sidebar clicking on Styles icon, displays the Style sub-

menu. 
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                     Figure 1.1                                               Figure1.2 

Fill Format   

Writer provides a convenient way of doing it through Fill Format option. It is second 

icon from right side on Style menu. This method is very useful when a same style is to 

be applied at many places scattered in the document. Fill Format can be used to style 

scattered – pages, frames, tables, lists, paragraphs or characters. 

To use Fill Format follow the following steps: 

Step 1. Open the document to be styled. 

Step 2. Open the Styles window and select the desired style category and then desired 

style from drop down list. 

Step 3. Select Fill Format button. 

Step 4. To apply the selected style, take the mouse pointer to desired location and 

click. Do take care to apply style on appropriate type of content. 

Step 5. Repeat step 4 until all the changes have been made for that style in entire 

document. 

Step 6. To quit Fill Format option, click the Fill Format button again or press the Esc 

key. 

Creating and Updating a New Style 

Custom Style can be created in many ways, two of which the simple ways are – From 

selection and second by using drag and drop. 

1. From Selection – Last button in Style menu, is Styles action button is used to 
create a new style or modify an existing style. It can be also used to load a style 
defined in document / template, in the list. 
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                Figure1.3 Figure1.4 

 

Step 1. Select the portion of document, such as page, paragraph, character, to change 

its appearance. Format it as per the requirement. 

Step 2. From the buttons at the top of the Style menu, choose the category 

(paragraph, character, page) for which new style is to be created. 

Step 3. Select Style action button. A list of options .Click on New Style from Selection. 

Step 4. In Create Style dialog window, type the name of new style, “My Style” . The 

names of existing styles are displayed in the window. 

Step 5. Click OK to save the name of new style. Observe that the name of the newly 

created style “My Style” is appeared in the list of styles. 

Updating a Style 

Instead of creating a new style for a small change in predefined styles, an existing 

Style can be modified on desired aspect. Using the second option Updating Current 

Style. 

Follow the following steps to modify an existing user defined style of page, frame or 

paragraph style. 

Step 1. Select the page / paragraph to be modified. 

Step 2. Format the selected portion as per the requirement. 

Step 3. Go to Style menu, and click on the button, whose style you want to update. 

Step 4. Using Style Action button, click on Updated Selected Style. 
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             Figure1.5 

Load Styles (from a template or document) 

The last option, in Style Action button of Style Menu is Load Styles. It is used to copy 

styles from an existing template or document. 

Step 1. In the Styles Menu , click on the Load Styles. 

Step 2. It will open the Load Styles dialog box. Choose the category of your document.  

Step 3. Find and select the desired template to copy styles from. 

Step 4. From the same dialog window, also, select the options for the types of styles to 

be copied, such as Text for Paragraph and Character styles, Frame, Pages or Numbering 

(List styles). By selecting Overwrite option, the styles being copied will replace any 

existing styles with same name. 

Step 5. Click OK to copy the styles. 

Step 6. In case styles are to be copied from a file, then instead of Template option, 

click on the From File button. 
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                     Figure1.6                                      Figure1.7 

Applying Styles  

Whenever a new document is created, Writer applies a default styles to it, and the 

same is displayed in status bar. 

  

                   

        

                       

 
 

                                             

 

 

 

                        

 

 

                                                        Figure1.8 
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Summary  

In this session, you have learnt about the create new Style, update or load existing 

Style in Writer document. 
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Chapter 2 

Introduction to Styles 

 

Introduction 

A document containing pictures is always easier to understand than a pure text 

document. Pictures have visual appeal, as our brain responds quickly to colors in 

comparison to any other form of information. A picture can be a drawing, chart, photo, 

logo, graph, or single video frame. In digital document a picture can be a graphic or 

image representation, which is a digital image. Till now, we have created a text 

document with different features such as formatting and using styles. In this chapter 

you will learn to create a document with pictures. 

Inserting An Image In A Document 

Libre Office Writer allows us to work on images, shapes, charts and diagrams by 

providing various tools. The image file stored on the computer, can be inserted into a 

document using different ways such as – using Insert Image dialog, using drag and 

drop option, using copy and paste option and lastly by linking. 

Inserting image using Insert Image option 

A general procedure to insert an image using Insert Image dialog box, is as follows: 

Step 1. Open the document to insert an image in Libre Office Writer. 

Step 2. Place the cursor where you want to insert an image. 

Step 3. Select and click on Insert > Image from menu bar 

Step 4. An Insert Image dialog box will open which will allow to choose the picture file 

to be inserted. 

Step 5. Select the file and click on Open button to insert an image in document. 

 

Inserting An Image In A Document: using drag and drop option 

Another option to insert images in the document is by using drag and drop option. The 

standard procedure is just drag the image from its source and drop it at desired 

position in the document. A general procedure to insert an image using Insert Image 

dialog box, is as follows. 
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Step 1. Open the document to insert an image in LibreOffice Writer. 

Step 2. Open a file browser window (Win+E) and select the image file to be inserted. 

Step 3. Drag the image into the document 

Step 4. Drop it, where you want it to appear in the document. 

 

Modifying An Image 

Sometimes we may require to modify the image inserted in the document to suit the 

document‟s requirement. The Image toolbar is used to resize, crop, delete and rotate 

the image. 

Using the Image toolbar 

The Image toolbar automatically appears when an image is inserted or selected in the 

document. If you want to keep it always remain on screen, click on View > Toolbars > 

Image from the menu bar. 

 

 

 

 

 

 

 

                                                    Figure2.1 

 

 

 

  

 



 

Page | 12  
 

Description of Image toolbar 

        Tool                  Effect on image 

Image Filter There are eleven types of filters available for improving an 
image. 

Image Mode Image can be changed to black & white, gray-scale or a 
watermark. 

Crop Cuts off non desirable part of the image. 

Flip Horizontally Flips the image Horizontally by 180o. 

Flip Vertically Flips the image Vertically by 180o 

Rotate 90o left Rotates the image by 90o left or right, depending on the 
button chosen. 

Rotate Image can be rotated by any angle using this tool. 

Transparency Makes an image transparent by using the value provided in 
percentage. 

Color Using Drop Down list, Red, Blue or Green color can be 

modified or adjustment for brightness, contrast and gamma 
can be made. 

 

Resizing an image 

Sometimes you may want to resize the image to fit an image at the desired place in a 

document. Resizing is the process of reducing or enlarging the size of the image. This 

can be done in various ways. Quick and easy way to resize an image is by dragging the 

image‟s sizing handles.  

Use the following steps to resize image: 

Step 1. Click on the image inserted in the previous activity. Observe that there are 

eight sizing handles surrounded the image. 

Step 2. Position the pointer over one of the sizing handle. The pointer changes shape 

indicating the direction of the resizing. 

Step 3. Click and drag to resize the image. 

Step 4. Release the mouse button when satisfied with the new size and observe the 

size of the image is reduced. 
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            Figure 2.2 

Deleting an image 

It is possible to delete the image from the document just like we delete the text. To 

delete the image, just select the image by clicking on the image and press the Delete 

key. 

DRAWING OBJECTS 

If you need to draw a flowchart or a call out box in your document, Libre Office Writer 

provides the feature of drawing tools for such work. The set of drawing tools available 

in Writer. Using Drawing Tools to display Drawing Toolbar in the Writer window, click 

on View > Toolbars> Drawing 

 

                   Figure 2.3 
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Drawing Objects 

There are many default drawing objects used to create designs in document. To use 

them – 

Step 1. Place the cursor in the document where you want the drawing to be placed 

(anchored). You can change the anchor later, if required. 

Step 2. Select the tool from the Drawing toolbar. The mouse pointer changes to a 

drawing-functions pointer. 

Step 3. Move the pointer to the place in the document where you want the image to 

appear and then click-and drag to create the drawing object. 

Step 4. Release the mouse button to finish drawing. 

Step 5. The selected drawing function remains active, so that you can draw another 

object of the same type. 

Step 6. To cancel the selected drawing function, press the Esc key or click the Select 

icon (the arrow) on the Drawing toolbar. 

 

 Figure 2.4 

 

Setting or Changing Properties of Drawing Object 

On selecting the drawing object, in the document, Drawing Object properties toolbar is 

displayed. 

To set the properties before drawing the object, follow the following steps: 

Step 1. From the Drawing Toolbar, select the object you want to draw. 

Step 2. From Drawing Object Properties Toolbar, click on the icon of property to be 

modified. 

Step 3. Change the value of parameter. 

Step 4. Repeat Step 2 and 3 to change all desired properties. 

Step 5. Draw the desired figure by following steps given in previous section. 
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              Figure 2.5 

Resizing and Grouping objects 

Sometimes you may want to change the size of drawing to accommodate it at a 

particular place in the document. This can be done either by changing its size only or 

by changing its shape and size both. Follow the following steps to resize a drawing. 

Step 1. Select the object to be resized. All eight handles on the corners and edges will 

be visible. 

Step 2. Click on any of the handles and drag it to its new place. The object will be 

scaled up or down, depending on your action. Also whether object‟s shape will be 

retained or not, will depend on the handle you choose for resizing. 

Step 3. For resizing and maintaining original shape of drawing, use corner handles. 

Step 4. Using edge handles will resize drawing non-proportionally. 

 

Grouping Drawing Objects 

Libre Office Writer allows grouping these different shapes, to behave as a single entity 

without affecting their size and position. Once grouped, all shapes belonging to that 

group become its member and a change applied on one member works on all. Follow 

the following steps to group the drawing objects. 

To group drawing objects: 

Step 1. Select the object by clicking over it. 

Step 2. Hold the Shift key and keep on selecting all other objects by clicking on it to 

be included in the group. 

Step 3. Select a group tool from Drawing Object Properties Toolbar. Alternatively, 

selecting from main menu Format > Group > Group will also do same work. 

Step 4. This process will group the selected drawing objects. 
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                            Figure 2.6 

Positioning Image in the Text 

Once the task of creating, formatting, resizing and grouping the drawing object is 

complete, it has to be positioned in the document with text and other image or 

drawings. Positioning of an image is controlled by four settings. 

1. Arrangement 

2. Anchoring 

3. Alignment 

4. Text Wrapping 

Arrangement – In overlapping objects arrangement determines the position of current 

drawing with respect to other drawings or text. The Drawing Object Properties toolbar 

consists of the arrangement tools. 

 

                        Figure 2.7 

Anchoring – Anchoring acts as a reference point for image or drawing. Anchoring 

allows an image to retain its position to a page, paragraph, character or frame. 

Alignment – Alignment allows the vertical or horizontal placement of the image with 

respect to its anchor. Alignment tools are located under Drawing Properties toolbar. 

An image can aligned in six different styles – 3 horizontal and 3 vertical. 

Text Wrapping – It allows the placement of image in relation to text. Text Wrapping 

tools are available under Drawing Object Properties toolbar. There are six choices 

namely, Wrap off, Page Wrap, Optimal Page wrap, Wrap left, Wrap right, Wrap 

through. 
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                   Figure 2.8                               Figure 2.9 

 

 

                                         Figure 2.10 

Summary 

In this session, you have learnt about the create insert, resizing and positioning of 

image in Writer document. 
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Chapter 3  

Advanced Features of Writer 

 

Session Objectives 

The students will be able to: 

 Overview Table of Contents. 

  Discuss hierarchy of headings. 

  Demonstrate creating a Table of Contents (TOC). 

  Describe maintaining a Table of Contents. 

  Demonstrate template: Creating a template, template: in-built saved templates. 

  Explain template: online templates, editing a template, exporting Template. 

 

Introduction 

As we all know that Libre Office Writer is a word processor that provides variety of 

features. We have already learned some of the features such as formatting, editing, 

inserting tables and images, styling the text and inserting graphics in the document. 

In this chapter we will be learning some advanced features of Libre Office Writer that 

will used to create professional documents. To give the listing of the contents of the 

document, we can use the Table of Contents feature which is based on different type 

of heading styles. Libre Office Writer also provides templates to create professional 

documents. 

Table of Contents 

In this chapter we will discuss the Table of Contents (TOC).“Table of Contents”, allows 

to insert an automated table of contents in a document. The entries or contents of this 

table are automatically taken from the headings and sub headings of the document. 

Also, these contents are hyperlinked in the table. So by clicking on any topic in the 

table of contents, we can navigate directly to the selected topic. But before creating 

table of contents, you need to first understand the concept of hierarchy of headings. 

Hierarchy of Headings 

Step 1. Create a new document in Libre Office Writer and enter the text Heading 1 to 

Heading 10. 
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Step 2. Click on the Styles button from the right side bar. Click on the Paragraph 

Styles and then Headings. 

Step 3. Place the cursor on Heading 1 as typed in the document. Then click on the 

Heading 1 from the Styles dialog window. 

Step 4. Repeat the Step 2 for the words Heading 2 to Heading 10. 

Step 5. Observe that the Heading 1 to Heading 10 is applied to the words Heading 1 to 

Heading 10 of the document and these headings has changed to applied style. 

 

                    Figure 3.1                                            Figure 3.2 

 

Creating a Table of Contents (TOC) 

Once a styled document is created, follow the steps given below to insert the TOC in 

the given document: 

Step 1. Open the earlier created file “documentation.odt”. 

Step 2. Assign proper heading styles to the various headings in the document from 

the Styles dialog box. For an example, assign the heading styles in the file. 

Step 2. Place the cursor at the position where the table of contents is to be inserted. 

Usually it is in the beginning of the document. 

Step 3. From main menu, select Insert > Table of Contents and Index > Table of 

Contents, Index or Bibliography. The Table of Contents, Index and Bibliography dialog 

box will be displayed. 

Step 4. By default, the Type tab will be selected with a preview of the TOC on the right 

side of the dialog box. On the left of the dialog box, is the Types and Title section. 

Step 5. Click OK button. The Table of Contents will be inserted in the Document. 
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                                                      Figure 3.3 

 

 

 

 

 

 

 

                                  Figure 3.4 

 

 Figure 3.5 
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Maintaining a Table of Contents 

Maintaining a Table of Contents consists of Updating the TOC and deleting TOC. To 

update a TOC manually, follow the following steps: 

Step 1. Right-click anywhere in the TOC. 

Step 2. From the pop-up menu, select Update Index option. Writer updates the TOC 

so as to reflect any changes made in the document. The reflected changes in TOC. 

Deleting TOC 

To delete the TOC, right click on the table and select Delete Index option from the pop-

up menu. The TOC will be deleted. 

 

                    Figure 3.6                                                Figure 3.7 

 

Template: Creating a Template 

Create your own template and save the current styles and appearance of a document 

for future use. Follow the following steps to create and save a template in Writer. 

Step 1. Open the document in Libre Office Writer whose template is to be created. 

Step 2. From main menu bar, select File > Templates > Save. The Save As Template 

dialog box appears. 

Step 3. Type the name of the new template (T1) in Template Name text box. 

Step 4. Select the category of the template being created. A category is just like a 

folder that helps to organize the templates. Some of the categories that can be seen in 

the dialog box are My Templates, Business Correspondence, Online Business 

Documents, Presentations. 
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Step 5. Click and select Set as default template checkbox to make the current 

template as the default template. 

Step 6. Click Save button to save the template. A template in Writer is saved with an 

extension .ott. Now this template file can be used by any document in Libre Office 

Writer. 

 

  

                                                            Figure 3.8 

Template: In-built/ Saved templates 

LibreOffice allows to use the in-built templates, online templates as well as the 

templates created and saved by us. Follow the following steps to use a predefined 

template to style a document. 

Step 1. Open the new document in Libre Office Writer. 

Step 2. From main menu bar, select File > Templates > Manage Templates. You can 

also use the keyboard shortcut key Ctrl+Shift+N to open the Templates dialog box. The 

Templates dialog box will be displayed. 

Step 3. Select the desired template, (say T1) and click Open button. The new 

document (with name as Untitled) will be opened with the same content, appearance 

and formatting effects as the saved template. 

Step 4. Make the desired changes and save the file. 
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               Figure 3.9 

Template: Online Templates 

Libre Office provides a wide range of online templates which can be downloaded from 

Internet. Once these templates are installed on your computer, they will be appear in 

Templates window. To view and select online templates provided by Writer, follow the 

following steps. 

Step 1. From main menu bar of Libre Office Writer, select File > Templates > Manage 

Templates. 

Step 2. Templates dialog box will be displayed. Observe the small circular icon Browse 

Online Templates in the lower left corner above the Help button. 

Step 3. Click on Browse Online Templates button on the bottom left of the Templates 

window. The official templates page of Open Office Writer 

(https://extensions.libreoffice.org/templates) will open in the browser. 

 

 

 

 Figure 3.10                                    Figure 3.11 

https://extensions.libreoffice.org/templates
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Template: Editing a template 

Once a template is created, desired changes can be made in it by following the steps 

given below. 

Step 1. Click File > Templates > Manage Templates. The Templates dialog box will be 

displayed. 

Step 2. Right click on the template file (say T1) that has to be edited. 

Step 3. Select the Edit option from the pop up menu. The template file will be opened. 

Make the desired changes and save the file. Now if we apply this template for any 

document, the edited file will be used. 

Template: Exporting a Template 

Export template allows to store the template file in the desired folder on your 

computer. It is different from moving a template from one category folder to another. 

Follow the steps given below to export a template: 

Step 1. In the Templates dialog box, select the template to be exported. 

Step 2. Click on Export button located in the bottom right of the dialog box. 

Step 3. Then the Select Path dialog box appears. 

Step 4. Select the folder and press on OK button. 

The selected template will be exported in that folder and a confirmation dialog box. 

 

 

                     Figure 3.12                                          Figure3.13 
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Summary 

In this session, you have learnt about the create, update and delete Table of Content 

with Template in Writer document. 
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Chapter 4 

 Analyse Data Using Scenarios and Goal Seek  

 

Session Objectives 

The students will be able to: 

 Explain consolidating data 

 Demonstrate subtotal tool 

 Explain what-if scenarios 

 Identify what-if Analysis tool 

Introduction 

Analyzing data is the process to extract useful information for making effective 

decisions. There are various data analysis software such as Calc, Excel and 

Python that are used to retrieve, correlate, explore and visualise data to 

identify patterns, trend sand relationships. Libre Office Calc includes several 

tools used to manipulate the data in the spreadsheet. 

Consolidating data 

 
Consolidate function is used to combine information from multiple sheets of 
the spreadsheet into one place to summarize the information. It is used to view 
and compare variety of data in a single spreadsheet for identifying trend sand 
relationships. 
 
Steps to consolidate the data are as follows: 
 

Step1. Open the spreadsheet which has the data to be consolidated. 

Step2. Create a new sheet where the data has to be consolidated. 

Step3. Choose Data>Consolidate option that will open Consolidate dialog. 

Step4. Observe that the default function “Sum” is seen  in the Function 

drop-down. You will be able to see the list of functions. 

Step5. Choose the required function from the drop-down list. 

Step6. The sources data range list contains existing named ranges to quickly 

select from that. But if the source range is undefined, then click and select the 

range from the sheet which is to be consolidated. 

Step7. Click on Add to add this range under the Consolidation ranges‟ of the 

Consolidation dialog. 

Step8. Repeat steps 6 and s teps 7 to add more sheets to be consolidated. 



 

Page | 27  
 

Step9.Remember to check the target range specified under Use „Copy results to‟. If 
it is not mentioned, then click on the cell of sheet where the final data has to be 
produced. 
Step10. Click on Options that will list two checkbox under Consolidate by“ 

Row labels” and “Column labels” and“ Link to source data” under Options. 
Step11.Finally click on OK button. 
 

 

 

 

 

 

 

                          Figure 4.1                                                     Figure 4.2 

 

 

  

 

 

 

 

 

 

 

 

 

 

 Figure 4.3 
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Sub-Total Tool  

Follow the following steps to apply Subtotal tool: 

Step1.The sheet where this is to be applied must have labels to the column. 

Step2. Click on Data menu and choose Subtotals (Data>Subtotals) 

Step3. Choose the column in the Group by list in the subtotal dialog which is 
to be used for grouping the data in the sheet. 

Step4. Select the column by clicking the checkbox under Calculate subtotals 
for that you want to create subtotals for. 
Step5.Select the function you want to perform for the selected column by 
clicking the function under Use function. 
Step6.You can use the 2nd Group and 3rd Group tabs if the 
Data has to be grouped in further levels. 
Step7. Click on OK button. 
 
 

F 

 

 

 

 

 

 

 

 

    Figure 4.4                                                          Figure 4.5 

 

 

What-if Scenarios 

 

What-if scenario is a set of values that can be used within the calculations in 

the spreadsheet. A name is given to the scenario and several scenarios can be 

created on the same sheet. 
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Follow the following steps to create scenario: 

Step1. Select the cells which contains values in the sheet that needs to be 
changed. To select multiple cells, hold Ctrl key and click on the cell to be 
selected. 
Step2. Choose Tools>Scenarios will open scenario dialog window. 
Step3. Enter a name for the new scenario and leave the other field sun 
changed. 
Step4. Click on OK 
Step5. This will create a new scenario which is activated automatically. 

 

 

 

 

 

 

 

 

 

 

   Figure 4.6 

What-If Analysis tool 

What-if tool uses Data>Multiple Operation and is a planning tool for what-if 

questions. 

Following steps are used for what-if analysis tool: Let us calculate with one 
formula and one variable: 

Step1. Enter the data in the cells and then enter a formula to calculate a 
result from values in other cells. 

Step2. Create an array of input values on the basis of which the output is to be 
generated using the formula. 

Step3. Select the cell range of input array and output array. 

Step4. Click on Data>Multiple Operations will display the multiple operations 

dialog window. 

Step5. Enter the cell address in the Formulas box from the sheet which 

contains the formula. 

Step6.Now enter the cell address of the cell which is a variable and is used in 
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the formula in Column in put cell box. 

Step7.Click on OK will generate all the possible outputs based on the formula. 

 

  

 

 

 

 Figure 4.7 

 

Summary 

In this session, you have learnt about the Libre Office Calc (Advance). 
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Chapter 5 

 Using Macros In Spreadsheet 

 

Session Objectives 

The students will be able to: 

 Demonstrate recording a macro 

 Explain running a macro 

 Demonstrate creating and organizing a simple macro 

 Discuss macro as a function 

 

Introduction 

Many times, we have to perform repeated tasks such as typing school name, 

address, contact numbers with a specific formatting or apply the same formula 

at a particular cell for different sheets in a workbook. In this chapter, we will 

learn how to use a macro to automate repeated tasks that are always 

performed in the same way over and over again. 

Recording a Macro 

It is important to know that by default the macro recording feature is turned 

off when Libre Office is installed on our computer. Hence, to record a Macro 

we need to ensure that the macro recording is enabled. Macro recording can 

be enabled using the Tools option on the main menu bar by selecting 

Tools>Options>Libre Office>Advanced. Observe the Optional Features. 

The Macro records all the keyboard and mouse actions but the following 

actions are not recorded. 

 Opening of windows. 

 Actions carried out in another window than where the recording was 
started. 

 Windows witching. 

 Actions that are not related to the spreadsheet contents. For example, 
changes made in the Options dialog, macro organizer, customizing. 

 Selections are recorded only if they are done by using the keyboard 
(cursor traveling),but not when the mouse is used. 

 The macro recorder works only in Calc and Writer. 

 

 



 

Page | 32  
 

 

 

 

 

 Figure 5.1                                                        Figure 5.2 

 

Running a Macro 

Let us now run the macro for another sheet which requires its 
heading in cell A1 to be given the same format given the same format 
as recorded in the Format heading macro. 

To run a macro we need to perform the following steps. 

Step1. Type the heading incellA1. 
Step2. Use Tools>Macros>Run Macro to open the Macro Select or dialog. 
Step3. Select the library and module in the Library list. 
Step4. Select the macro in the Macro name list.  
Step5. Click Run to run the macro. 

 
 

 

 

 

 

 

 

 

 

                                                            Figure 5.3 
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Creating and Organizing a simple Macro 
 
The recorded macro is internally stored as instructions written in a 

programming language that are executed when the macro is executed or run. 
We selected    a library or module to store our recorded macro, similarly while 
creating a macro we need to either create a new library/module or edit an existing 
module stored in a  library  to store our created macro. 
 
 
Use the following steps to organize the macro. 
 
Step1. Click on Tools >Macros > Organize Macros > Libre Office Basic to open 
the Libre Office Basic Macro dialog window. 
Step2.Click Organizer to open the Basic Macro Organizer dialog 
 
 

 

 

  

 

 

 

 

                    Figure 5.4                                                             Figure 5.5 

Macro as a function 

 
Consider a situation where in you need to perform calculations that are 

repetitive in nature. Assume that the same formula needs to be applied to 
different data in different sheets and there is no predefined function for it. 
It is possible to do so if we use Macro as a function .Instead of writing 
instructions in between Sub and End Sub, we can write instructions in 
between Function and End Function. A function is capable of accepting 
arguments/values. It can perform operations on the arguments, perform 
calculations and return the result. 
 
Summary 

 
In this session, you have learnt about the Macro in Calc. 
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Chapter 6 

 Linking Spreadsheet Data 

 

Session Objectives 

The students will be able to: 

 Explain setting up multiple sheets. 

 Demonstrate creating reference to other sheets. 

 Identify hyperlinks to the sheet. 

 Explain creating hyperlinks. 

 Describe linking to external data, registered data sources. 

 

Introduction 

 
In this chapter, we will learn how to create multiple sheets, and also to link the 
data in multiple sheets. It can be done in two ways, one is creating reference to 
other sheets/documents by using keyboard and mouse, and other is by linking 
external data. 
 

Setting up multiple sheets 

Let us consider a worksheet storing  marks  of  the  first  term  in  a sheet named 
Term1. 
To add a new sheet in the spreadsheet, click on the Add Sheet by clicking on 
the (+) sign located in the left bottom of the spreadsheet. Alternatively you can 
right click any where on the sheet tab and select Insert sheet option from the 
drop-down list displayed. 
Note–Insert Sheet dialog box can be invoked from the menu option 
Sheet>Insert Sheet 
 

 
 

 

 

 

 

 Figure 6.1 



 

Page | 35  
 

 

 

 

 

 

 

 Figure 6.2 

 

Creating reference to other sheets 

 
To calculate the final result, it is required to store the final marks for each 
subject in the sheet named “Result” inserted in Activity 6.1 by applying the 
formula (Marks obtained in Term1 + Marks obtained inTerm2)/2.As we know 
that marks obtained in Term1 and Term2 are stored in different sheets named 
Term1 and Term2 respectively. To calculate the final marks for English in the 
cell C4 of Result sheet,  
 
Follow the following steps. 
 
Step 1. First copy the RollNo and Name of the Student from Term1 sheet to 
Result sheet, copy all headings of and give the name  as Final Result. 
Step 2. Click on the = icon next to the input line (or type = in cell C4), type 
Sum()and click between the brackets. 
Step3.Now click on the Term1 sheet and click the English Marks for the first 
student and add(,)comma for the next value. 
Step 4. Next click on the Term 2 sheet and click the English Marks for the first 
student. 
Step 5. To calculate average type /2 after the sum() to  calculate average. 
Step 6. Press Enter key, the average is displayed in cell C4 of Result sheet. Then use 
fill handle to fill the cells up to the last student‟s data. 
Step 7. The result sheet gives the average marks scored by each student in English. 
Step 8. You can copy the same formula for other subjects. 
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                            Figure 6.3 

 

Hyperlinks to the sheet 
 
Sometimes it is required to jump to a document stored at a different location 

from within a document. It can be done by creating a hyperlink. It is possible 
to jump from a sheet in the same spreadsheet ,different spreadsheet or a 
website by creating a hyperlink. Relative and absolute hyperlinks. A hyperlink 
can be either absolute or relative. An absolute hyperlink stores the complete 
location where the file is stored. 
 
For example: C:\Users\ADMIN\Downloads\try.ods is an absolute link as it 
defines the complete path of the file. 
 
A relative hyperlink stores the location with respect to the current location. A 
relative hyperlink stores the location with respect to the current location. 
 
For example: Admin\Downloads\try.odf 
 

Creating Hyperlinks 

 
It is possible to hyperlink a sheet of other spreadsheet document in a spreadsheet. 

 
Editing a Hyperlink 

 
To edit an existing link, place the cursor anywhere in the link and right click the 
hyperlink. Click on Edit Hyperlink..., the Hyperlink dialog box will be 
displayed. Where you can make changes to the hyperlink. 
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                                                Figure 6.4 

                                                 Figure 6.5 

 

Linking to external data 

 
Internet is a rich source of information, which is stored in the form of web 
pages. The web pages are written in HTML documents. Data on a web page 
can be stored in the form of tables. 
To insert the tables from a HTML document, we can use the External Data 
Dialog box.  

 
The steps for the same are given below. 
 
Step1. Open the spreadsheet where external data is to be 
inserted. 
Step2. Select the cell to store the first cell of the table in the external data. 
Step3. Select Sheet>Link to External Data. 
Step4. The External Data dialog box  is displayed. Type the URL of the source 
document or select it from the drop-down list if it is listed and press enter. 
Step5. A dialog box is displayed to select the language for 
import. 
Step6. From the Available Tables/Ranges list, choose the 
Desired table. 
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                      Figure 6.6                                                    Figure 6.7 

Linking to external data 

 
Internet is a rich source of information, which is stored in the form of web 
pages. The web pages are written in HTML documents. Data on a web page 
can be stored in the form of tables. 
To insert the tables from a HTML document, we can use the External Data 
Dialog box.  
 
The steps for the same are given below. 
 
Step1.Open the spreadsheet where external data is to be 
inserted. 
Step2. Select the cell to store the first cell of the table in the external data. 
Step3. Select Sheet>Link to External Data. 
Step4.The External Data dialog box is displayed. Type the URL of the source 
document or select it from the drop-down list if it is listed and press enter. 
Step5. A dialog box is displayed to select the language for 
import. 
Step 6. From the Available Tables/Ranges list, choose the Desired Table. 

 
 

   

 

 

 

                     Figure 6.8                                                     Figure 6.9 
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                                                 Figure 6.10 

 

Linking to registered data sources 

 
Libre Office Calc allows us to link spreadsheet documents with databases and 
other data sources. The data source needs to be registered with Libre Office. 
You can access a variety of databases and other data sources and link them to 
Calc documents. To register a data source that is in *.odb format. 
 
 Follow the steps given below: 
 
Step1.SelectTools>Options>LibreOfficeBase>Databases.TheOptions-Libre 
Office Base-Databases dialog box appears. 
Step 2. Click the New button to open the Create Database Link dialog box. 
Step3.Enter the location of the database file, or click Browse to open a file 
browser and select the database file. 
Step4. Type a name to use as the registered name for the database and click OK. 
 
 

 

 

 

 

 

 Figure 6.11 

Summary 

 
In this session, you have learnt about the Hyperlink in Calc. 
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Chapter 7 

 

Share and Review a Spreadsheet 

 
 

Session Objectives 

 
The students will be able to: 

 

 Demonstrate sharing spreadsheet. 

 Explain opening and saving a shared spreadsheet. 

 Discuss add, edit and format the comments. 

 Identify reviewing changes–view, accept or reject changes. 

 Describe merging and comparing. 

 

 

Introduction 
 
In Libre Office Calc, one spreadsheet can be used by more than one user at a 
time by sharing it. A shared spreadsheet is a same sheet that can be accessed 
by more than one user and can allow them to make changes simultaneously 
on it. This can be done while working on it simultaneously at the same time or 
maybe working on it at different point of time. This will save us from the 
trouble of keeping track of multiple copies of the same spreadsheet. Sharing 
allows working in collaboration so that everyone can contribute, make changes 
and view it. 
 
Sharing Spreadsheet 
 
Sharing a spreadsheet is just like a team work to work in collaboration with 
other users.  
 

The following are the steps to share the spreadsheet. 
 
Step1. Open a new spreadsheet and save it with some name. 
Step 2. Select and click on Tools > Share Spreadsheet from main menu bar. 
This will open the Share Document dialog, which can be used to enable or 
disable sharing option. 
Step 3. Click on the checkbox “Share this spreadsheet with other users to share 
the spreadsheet  and  click  on  OK button. This will open the confirmation dialog  
window  to save the spreadsheet to activate the shared mode. 
Step4. Click on Yes to continue. 
Step5. Once the spreadsheet is saved, the name of the spreadsheet in the title 
bar will display (shared) along with the name of the spreadsheet. 
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 Figure 7.2 

 

 

 

                     Figure 7.1 

 

Opening and Saving a shared spreadsheet 

 
Opening Spreadsheet 
 
To open a shared spreadsheet Follow the following steps: 
Step 1.  While opening a spreadsheet which      is      a    shared 
spreadsheet, a message will appear. 
Step2. Click on OK button to open the spreadsheet in shared mode. 
Step3. If you don‟t want this warning option to be displayed again, then check 
the mark in the checkbox „Do not show warning again‟. 
Step4.Once the spreadsheet is saved in shared mode, some of the features will 
become unavailable for used. 
Step5.Observe the Edit menu on them in a menu bar. 

 
 

 

 

 

 

 Figure 7.3 

 

 

                                                                                                    Figure 7.4 
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Add , Edit and Format the Comment 

 
In Calc, the comments are automatically added. Also, the author or reviewer 
can add their own comments as well. 
Follow the following steps to add your comments: 
 
Step 1. Select from main menu bar and click on Edit>Track Changes> 
Comment. 
Step2. This will open the Add comment window. Enter your comments. 
Step3.Now to view the entered comment, click on the cellB6. 
Step4. You can also insert comments to a cell. Then select from main menu 

Insert>Comment 

 

 

                 Figure 7.5                                                     Figure 7.6 

  

 

 

 

 

 

 Figure 7.7 

Step 5. This type of comments is known as notes or suggestions in the 
spreadsheet. 
Step6.Once the comment is added, you can display, edit or delete it. 
Step7. Select the “Edit Comment” option to edit the comments. It will take you 
again to the comment textbox to make any changes. 
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Step8. Select “Delete Comment” option to delete the comment. 
Step9. Select the “Show Comment” to view the comment. 

 
                         Figure 7.8                                       Figure 7.9 

Reviewing changes–view, accept or reject changes 
Once the spreadsheet is edited by all the members of the team. It is the final 
stage before submitting the spreadsheet. The changes to accept or reject to 
prepare the final spreadsheet after looking at all the changes made by the 
team members. 
Follow the following steps to review changes: 
 
Step1. Select and click on Edit>Track Changes>Show. It will open the Show 
Changes dialog window. 
Step 2. This is used to plan what all changes are to be 
Displayed while reviewing the spreadsheet. 
Step3.Click on Edit>Track Changes>Manage to accept 
Or reject the changes. 
Step 4. In this dialog window, click on the line and click on Accept or Accept All or 
Reject All button to review  the changes. 

Step5.Click on Close button once the review is done. 
 

 

 Figure 7.10 

 

 

 

                                                                                      Figure 7.11 
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Merging and comparing 

 
If the same spreadsheet is reviewed by different team members and you have two 
different versions of the same spreadsheet file. 
 
Follow the following steps to merge document. 
 
Step1. Open the spreadsheet file. Also note the contents of other spreadsheet. 
Step2. Click on Edit>Track Changes>Merge Document. 
Step 3. Select the spreadsheet file from the Merge With dialog window to open the 
other spreadsheet to merge with Test.ods and Click on Open button. 
Step4. This will open Manage Changes dialog window. 
Step5. Click on Accept. 
Step6.Now open the first spreadsheet. 

 

 

  

 

 

Figure 7.12                            Figure 7.13                                    Figure 7.14 

 

 

  

  

 

 

 Figure 7.15                   Figure 7.16                               

                                                                                                               Figure 7.17 

 

Summary 
 
In this session, you have learnt about the spreadsheet sharing. 
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Chapter 8  

Introduction to Database Management System 

 

 

Session Objectives 

The students will be able to: 

 Overview of data and information. 

 Explain databases and DBMS. 

 Discuss advantages of DBMS. 

 Identify data models. 

 Describe relational database model. 
 

Introduction 
 
Databases and database systems are essential parts of our life. We have been 
interacting with databases since long time. Remember, looking for a word in a 
dictionary or finding the telephone number of a friend from the telephone directory. 
With the advancement in technology, computerized databases are being used to store, 
manipulate, and manage the database. 
 

Data and Information 
The raw facts constitutes data. The facts may be related to any person, place, 

activity or things. It may be stored in the form of text, graphics, audio or video. 

Information is the processed or organized form of data. If data is not correct or 

accurate, the information obtained by processing such data may not be correct. 
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                                 Figure 8.1    Data stored in tabular form 

Databases and DBMS 

A database is a collection of logically related data items stored in an organized 

manner. The information being stored in a database can be added, modified 

,deleted or displayed according to the requirements of the user. The software 

that is used to create, update and retrieve data is known as database 

management system(DBMS). 

Advantages of DBMSusdiscusssome oftheadvantagesofDBMS: 

Organized storage –The data in the database is stored in an organized 

manner, so that retrieval of the required data is fast and accurate. 

Data analysis–A database helps in analysis of data based on certain criteria .It 

is easy to find out maximum or minimum value, average or mean using a 

database. 

Data sharing – If the same data set is required for different applications then 

the database can be shared with other applications. Hence using a database 

means making once and using it repeatedly for many. 

Minimal Data redundancy– In the event of requiring the same data field in 

several tables the data field might get repeated in number of tables. This is 

called as data redundancy .This can be reduced by using DBMS tools. 

Data consistency– By minimizing data redundancy, chances of inconsistent data 

being stored is reduced. For example, it should not happen that the name of the 

student is changed in one table and not in another. Such inconsistency is reduced 

by using a DBMS. 

Advantages of DBMS 
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Increases efficiency–Since database tables are properly organized, saving, 

reading and searching data can be carried out efficiently. 

Increases accuracy–Since data redundancy and inconsistency can be minimized 

in a database, the data is retrieved accurately from the database. 

Increases validity–Properties of different data fields can be assigned when a 

database is planned. So whether or not valid data is being entered can be checked 

at the data entry stage. This increases the validity of the database. 

For instance, we may set up a restriction while creating the table that the amount  

of fees being entered should be more than 1000. 

Security – Unauthorized access can be controlled by assigning passwords to 

the users. The data might be translated in such a manner that unauthorized 

users are not able to read it. This is known as encryption. Both these 

measures increase the security of the database. 

 

Data Models 

A database can be designed in different ways depending on the data being 

stored. This structure of database is known as data model that describes the 

manner in which data will be stored and retrieved. 

A data model consists of components for describing the data, relationships 
among them and the constraints that hold data. There are different data 

models such as hierarchical data model, network data model and relational 

data model. 

Hierarchical Data Model – In this model the data is organized into a tree like 

structure. The data is stored in the form of records. A record is a collection of 

fields and its data values. All these records are linked to each. 
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 Figure 8.2 

Network Data Model –In this model, multiple records are linked to same master 

file. It is also considered as an inverted tree where  master is present in the  

bottom of the tree and the branches contain information linked to the master. 

 

 Figure 8.3 

Relational Data Model–This data model is based on the principle of setting 

relationships between two or more tables of the same database. It is the most 

commonly used database model. 

Relational Database Model 

The Relational Database Model was proposed in 1970 by E.F.Codd. Relational 

database model is the most common type of database model. The data 

elements are stored in different tables made up of rows and columns. 

 

Relational Database Terminology 
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Let us get familiar with some of the common terms used  in  RDBMS. 

 Entity  – It is a real world object about which information is to be stored in a 

database. For example, if we want to store information about an entity Student, 

then we need to have his admission number, roll number, name, father‟s name,  

date of birth etc. These details associated with the entity are called attributes. 

Table – A table is a collection of logically related records. It is organized as a 

set of columns, and can have any number of rows. For example, the Employee 

table can have columns namely, name, designation, department and have 

records or rows having data of 100 employees. 

Field or Columns or Attributes – A field is the smallest entity in the 

database. A collection of fields make a record, a collection of records make a 

table and a collection of tables make a database. Fields are individual record 

characteristics and represented as columns within a table. Data values are 

stored in a database as fields. 

 

Relational Database Terminology 

Data Values – Data values are the raw data represented in numeric, character 

or alphanumeric form. 

Record or Row– The data values for all the fields related to a person or object is 

called a record. It is presented as rows within a table. A record holds the data 

values of all the fields for a  single  person  or object in a table. 

Primary Key – A primary key or simply a key is a field that uniquely identifies row 

in a table. The key identifier can be the  value  of  a single column or of multiple 

columns. The primary key is a unique identifier for the table. The column or 

combinations of columns that form the primary key have unique values. 

 

Relational Database Model  

Relational Database– A relational database is a collection of related tables. 

Foreign Key: If afield or a combination of fields of one  table can be used  to  

uniquely identify  records of an other table, then that  particular  field is  called as 

the foreign key. 
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Candidate Key– All the field values that are eligible to be the primary key are 

the candidate keys for that table. Such fields can neither be left blank nor can 

have duplicate values. 

Alternate Key– Out of the candidate keys, one or two are made as primary keys. The 

others are the alternate keys. 

 

 

 

 

 

 

 

 

Figure  8.4 

 

 

Relational Database Model 

Objects of an RDBMS An object in a database is a structure or a feature that 

is used to store, represent or retrieve data. In fact a database is a collection of 

these objects that work on multiple sets of data related to each other. Various 

objects in a database are as discussed below: 

Table – As mentioned before, a table is the basic unit of any DBMS. The data is 

first stored in tables in row and column format. A column  represents  a  field  or  

an attribute while a row represents a record. 

Forms–A form is a feature of a database using which we can enter data in a 

table in an easy and user friendly manner. 

Queries–A A query is used to retrieve the desired information from the 

database. In simple terms, it is a question asked from the database. 

Reports – The output of a query may be displayed in the form of reports. The 

usual result of the query is in the form of rows and columns. But if we want the 
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report to be form a landing proper layout, then we can use the Reports feature of 

RDBMS. 

Summary 

In this session, you have learnt about the database, data models and its 

advantages. 
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Chapter  9 

Starting with Libre Office  Base 

 

Session Objectives 

The students will be able to: 

 Identify data types. 
 Demonstrate starting with Libre office base. 
 Explain creating a table. 
 Demonstrate creating table in design view. 
 Perform data editing. 

 Discuss sorting data in the table. 
 

Introduction 

Libre Office Base is a free and open source DBMS. It can be downloaded from 

www.libreoffice.org and is available for both Linux and Windows operating systems. 

Data has to be stored in an organized manner using a DBMS. Also, the data being 

stored can be a text, number, date or in any other form. So, we need to understand 

different types of data that can be stored in a table. The data types of the fields have to 

be specified while creating tables in a database. There after valid data is entered and 

stored in a table. 

Data Types 

A data type refers to the type of data that will be stored in that particular field. The 

memory size of a field varies according to its data type. Some commonly used data 

types are described below.  

Text Data Type – The text data is a combination of letters, numbers or special 

characters. No arithmetic calculations can be performed on text data. Examples of text 

data type is PAN Card Number, Name, Marks. 

Numeric Data Type – Numeric data types consists of numbers. The numbers can be 

integer or real numbers on which any type of arithmetic calculations can be 

performed. 

Currency Data Type – The currency data type indicates the monetary values and can 

be stored using currencies of various countries. 

Date Data Type – This data type is used to indicate dates and time. Boolean – In 

Boolean data type there can be only two values- True or False. 
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Binary – The Binary data type used to store digitized images and sounds that comes 

as long string of zeros and ones. It is possible to store photos of the products or 

employees, or sound snippets or voice messages in Base Database. 

 

Starting with Libre Office Base 

Follow the following steps to create the database. 

Step 1. Start the Libre Office Base as per the standard process of starting the 
application in Windows or Linux. In Windows, click Start > Libre Office or double click 
on the Libre Office icon on the desktop or Select Base Database option from the 
bottom left panel. 

Step 2. A Database Wizard opens. It allows you to create a new database or open an 

existing database 

Step 3. Since we want to create a new database, so click Create a new database radio 

button. 

Step 4. The Next step gives the option to register our database with LibreOffice.org. 

Step 5. This step also asks whether you want to open the database for editing or want 

to create a table using the wizard. The option Open the database for editing is already 

selected. 

Step 6. Click Finish button to complete the database creation process. The Save As 

dialog box appears. 

Step7. Browse for the drive and folder where you want to store your database. 

Step 8. Type the name in the File name text box. 

Step 9. Click Save button. 
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 Figure 9.1 

 

 

 Figure 9.2 

                                               

                                                          

                        Figure 9.3 

 Figure 9.4 

 

Creating a table 

Once the database is created, we can start working with objects of the database. First 

and foremost is the creation of the table and then entering data in the table. A table in 

Libre Office Base can be created using a wizard or using the Design view. 

Creating a table using a wizard 

A table can be created at the time of creating a database or after creating database. To 

create a table at the time of creating a database in database wizard, select the radio 

button with option “Create tables using the table wizard”, then click on the Finish 
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button. The Table Wizard of Base consists of ready-made tables. Click the Sample 

tables list box and select any one table, say Customer from the drop down list. 

 

 

 
 

                          Figure 9.5                                           Figure 9.6 

 

Creating a table 

 Click on Next button. It will move you to step 2. 

 Click on Next button. It will move you to step 3. 

 Click on Next button, that will take you to the complete the process of creating 
table using wizard and display the screen. This screen will give you three 
choices. By default the “Insert data immediately” option selected. 

 Click on the Finish button to complete the process of creating the table and 
using wizard. 

 

                                 Figure 9.7                                           Figure 9.8          
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                            Figure 9.9                                        Figure 9.10 

 

Creating Table in Design View 

To create table using Design View, in main Database window, click on the option 

Create Table in Design View in the Tasks Pane and Table Design Window. The screen 

is broadly divided into two sections or horizontal panes. The upper half consists of a 

grid structure with three columns Field Name, Field Type and Description. 

Field Name – It is the name of the field assigned at the time of creation of table. 

Field Type – It allows to assign a data type to the field. 

  

 

                          Figure 9.11 
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                       Figure 9.12                                         Figure 9.13 

Editing Data 

Editing Data 

To edit or modify the previously entered data simply place the cursor on the field value 

that has to be edited to edit and enter the new value. The Edit icon ( ) appears before 

the record that is being edited. This icon is displayed till the table is saved after 

making the required changes. Press Esc key to cancel the corrections made and 

restore the original contents. 

Deleting Records from Table 

To Delete any record from the table, open the table and select the record to be deleted. 

The record can be deleted by pressing the Del key from the keyboard or selecting the 

Delete Record option from the Edit menu. Alternatively a record can also be deleted by 

right clicking on the record and clicking on the Delete Rows option from the pop up 

menu. 

 

 

                                           Figure 9.14 
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Sorting Data in the Table 

Data in a table can be arranged in ascending or descending order. This process of 

arranging the records in particular order on any filed is called as sorting. 

Follow the following steps to sort the table: 

Step 1. Open the Event table in datasheet view and select the field on which you want 

to sort. The field “Points” is selected to sort the records in ascending order. 

Step 2. From the tool bar click Sort Ascending icon if the table has to be sorted in 

ascending order of selected field. Alternatively select Sort Descending icon if the table 

has to be sorted in descending order of selected field. 

Step 3. The table will be sorted in the ascending order of points 

 
                    Figure 9.15                                        Figure 9.16 

 

   

                                                                   Figure 9.17 

Summary 

In this session, you have learnt about the data types and working on Libre office Base. 
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Chapter10 

Working with Multiple Tables 

 

Session Objectives 

The students will be able to: 

 Demonstrate editing and deleting tables 
 Identify relationships between tables 
 Classify types of relationships 
 Explain advantages of relating tables in a database 
 Discuss referential integrity 

 

Introduction 

We have learned to create tables in a database. Once the tables are added in a 

database, you may require to edit or delete the table. Also relations are set up 

between the table to control data redundancy and inconsistency. This helps in 

proper maintenance of a database by checking that neither the records are 

duplicated nor there is variable data value for a particular field in two or more 

tables. If you set up relations between tables, then adding or updating are cord 

in one table reflect the changes in all the related tables. 

Editing and Deleting Tables 

Editing a table involves the task such as adding a new field or removing any 

field in a table or to alter any of the field properties. To edit a table, open the 

Database User Interface window. Selecting the Table object in Database Pane, 

the list of tables will be displayed in the Table Area. Right click on the table 

name and select Edit option from the pop menu. 
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            Figure 10.1                                                    Figure 10.2 

 

Editing and Deleting Tables 

Similarly to delete a table, right click on the table to be deleted, say Customer 

table and select the Delete option from the pop up menu. A confirmation box to 

confirm for deletion of the table.To rename a table, right click on the table name 

in the Table Area and select Rename.. option from the pop up menu. A cursor 

will appear. Type the new name and press the Enter key. 

 

 
 

                             Figure 10.3                                         Figure 10.4  
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Relationships Between Tables 

While working with multiple tables, you need to check the redundancy and 

inconsistency of data. The record for a particular entity should neither be repeated 

nor different data values should appear for a single entity in the database. 

This is done by setting relationship between the tables of a database. The most 

important prerequisite for setting a relationship is that there must be a common 

field(s)between the two tables to create a relationship. 

 

Types of Relationships 

Primarily three types of relationships can be set up between two tables in a 

relational database. These are: 

i. One-to-One 

ii. One-to-many 

iii. Many-to-Many 
 

One-to-One Relationship 

In this type of relationship, one specific record of a master table has one and only 

one corresponding record in the transaction table. 

One-to-Many Relationship 

This is one of the most common types of relationship between the tables in a 

database. As the name says, in this type of relationship, one specific record of 

the master table has more than one corresponding records in the related 

transaction table. 

Many-to Many-relationship 

In this type of relationship, there will be multiple records in the master table 

that correspond to multiple records in the transaction table as well. Generally 

this type of relationship is set when certain records have to be saved more 

than once In both the related tables. 

 

Advantages of Relating Tables in a Database 
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There are various advantages of relating tables in a database. Few of them are as 

below. 

 A relationship can help prevent data redundancy. 

 It helps prevent missing data by keeping deleted data from getting out of synch. 
This is called referential integrity. 

 Creating relationships between tables restricts the user from entering invalid 
data in the referenced fields. 

 Any updation in the master table is automatically reflected in the transaction 
tables 

 

Referential Integrity 

According to the principle of referential integrity, no unmatched foreign key 

values should exist in the database. Libre Office Base gives us following four 

options to choose from to maintain referential integrity in such cases. 

No action – This is the default option. This option states that a user should not 

be allowed to update or delete any record in the master table if any related 

record exists in the transaction table. 

Update cascade– This option allows the user to delete or update the 

referenced field but along with it all the related records in any of the 

transaction tables will also be deleted or updated. 

Set NULL – This option assigns NULL value to all the related fields if the 

master record is deleted or updated. 

Set default–This option assigns any fixed default value to all the related fields 

if the master record is deleted or updated. 

Summary 

In this session, you have learnt about the working with multiple tables. 
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Chapter 11 

Queries in Base 

 

Session Objectives 

The students will be able to: 

 Explain queries 

 Demonstrate creating a query 

 Discuss creating a query In design view 

Introduction 

A database is used to store data in an organized manner so as to retrieve it easily 

and accurately from database. To search for the desired record and to retrieve the 

desired data, we have to give its specifications to DBMS.  Such specifications are 

given to the database in the form of queries. We can say that a query is a sort of 

question asked from a database. Depending upon specifications given in the 

query, the specific records are searched form the tables in the database and then 

displayed in the desired manner. 

Queries 

A query is one of the most important feature of any DBMS.  Using a query, we can 

retrieve and display data from one or more tables in a database. This is done by 

giving specific search criteria to the DBMS so that we are able to view the exact 

information that we want. 

Libre Office Base allows us to create a query and even save it as an object in a 

database. This helps us to run the query multiple times as and when required. 

Using a query, we can specify the fields that we want to display and also the 

criterion based on which the records to be filtered. The information may be 

retrieved from a single table or from multiple tables. Also the result of the query is 

displayed in tabular form with field names in columns and the records in rows. 

Creating a Query 

A query can be created in three ways. In this chapter you will earn the  first  two  

methods  to create a query. 
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i. Using a Wizard 

ii. In Design View 
iii. In SQL view 

 

To create a query using a wizard, follow the following steps.  

Step1.In the Database Design window, click on Queries button present in the 

Database Pane. 

Step2.In the Tasks Area, click on Use Wizard to Create Query option. 

 

                      Figure 11.1                                               Figure 11.2 

Step3.The first step of the wizard is to select fields from the Respective tables. 

Step4. Select Event Name field from the list box and click the right 

arrow(˃)button. The field name will appear in the Fields in the Query list box. 

Step5. Clicking on the Next button wil l  display the screen to select 

the sorting order. 

Step6.The next step is to set the search conditions or the criteria on the basis of 

which records will be filtered from the table. 

Step7.Select field from Fields drop down list, is equal to fromCondition. 

Step8. Steps 4, 5 and 6 given in the Steps Pane deal with tasks like summarizing and 

performing numerical calculations. 
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                      Figure 11.3                                    Figure 11.4 

 

  

 Figure 11.5 

Step9.The next step to give alias name i.e. the column header name will be 

displayed when we run the query. 

Step 10. The last step of the Query wizard displays the entire overview of the 

query. 

Step12.Click on Finish button. 

 

 

 
                         Figure 11.6                                        Figure 11.7 
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 Figure 11.8 

Creating a Query in Design View 
 

Another way to create a query is using the Design view. This is a more flexible 

method to create a query from either single or a multiple tables of a database. 

Follow the following steps to create a query in Design View: 

Step1.Click Queries icon on the Objects Pane in the Database Window. 
 
Step2.Click Create Query in Design View icon in the Tasks Pane. The Query 

Design Window appears. 

Step3.Click on the Event table to be used in the query and then click on Add 

button. 

Step4. Similarly add table to Tables Pane of the Query Design window. 

Step5. Click Close button in the Add Table or Query dialog box to close it. 

 
                        Figure 11.9                                     Figure 11.10 
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Step6.Next step is to select the fields. 

Step7.In the grid, there is a row titled Alias. As mentioned before, it can be 

used to display meaningful names in the output. 

Step8.By default, the data that is displayed as are result of the query is not 

sorted. To sort the records in either ascending or descending order of a 

particular field, the Sort row is given in the grid. 

Step 9. Once the query is designed, click Run Query ( ) button on the toolbar or 

press F5 key. 

Step10.Click on Save button to save the query. 

Step11.By default, the Query Name as Query1 will be  displayed. Type a 

different name if required. Click on OK button to save the query. 

Figure 11.12 

             Figure 11.11 

   

 

 

Figure 11.13 

 

Summary 

In this session, you have learnt about the query and methods to create query. 
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Chapter12 

Forms and Reports 

 

Session Objectives 

 The students will be able to: 

 Overview of forms. 

 Demonstrate creating a form using a wizard. 

 Discuss forms control toolbar. 

 Explain report. 

 Describe reports: create a report. 

 Identify reports: inserting date and time. 

 

Introduction 

Libre Office Base provides the Form feature for data entry purposes. Also, when the 

user wants to retrieve and view the data from one or more tables in a database using 

queries, it is again displayed in datasheet view. The Report feature of Open Office Base 

helps to present the retrieved data in a user friendly, understandable and formatted 

manner. 

Both reports and forms are considered as objects of the database and are present in 

the Database Pane of the Libre Office Base User Interface. 

Forms 

A form is an object of the database that has a user friendly interface where data can 

be entered and seen in an attractive and easy-to-read format. For any database, it is 

the front end for data entry and data modification. It displays the data in a layout 

design by us and not just in a simple row and column format. 

Primarily, a form contains field controls arranged in a presentable and user friendly 

manner. Each field control consists of a label and the field value text box. 

There are two ways to create a form: 
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 Using a wizard 
 

 Using the Design View 

 

Creating a Form Using a Wizard 

This is the simplest way to create a form. To create a form using wizard, follow the 

following steps. 

Step 1. Open the Sports Day database created in Libre Office, and click the Form icon 

on the Database Pane. 

Step 2. The step 1 of the wizard is to select the tables or queries for which the form 

has to be created. 

Step 3. After selecting the table, all the fields of the table will be listed in the Available 

Fields list box. 

Step 4. As we require all the fields to appear in the Form, shift all the fields of table 

from Available Fields list box to Fields in the Form list box using >> button. Click on 

Next button to move forward. 

 

 

                     Figure 12.1                                Figure 12.2 
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                    Figure 12.3                               Figure 12.4 

Step 5. The second step consists of setting up a sub form i.e. a form within a form. 

Step 6. The wizard skips the next two steps that relate to the sub form and moves on 

to step 5. 

Step 7. Click Next button. 

Step 8. The step 6 of the wizard asks whether the form will be used for displaying 

data, entering data or both. 

Step 9. The next step is to apply styles to the form being created. 

Step 10. Click Next button. 

Step 11.The next step is to setthe name of the form. 

Step 12.Click Finish button. 

 

 

 

                Figure 12.5                                 Figure 12.6 

  

 



 

Page | 71  
 

 

 Figure 12.7                         Figure 12.8 

 

  

 

                            Figure 12.9                                    Figure.12.10 

 

Forms Control Toolbar 

Forms Control Toolbar – This toolbar contains various controls that can be added to 

the form. 

Records Toolbar – The Records toolbar contains the navigation control buttons in the 

extreme left. With the help of these buttons, we can traverse and view the records in 

the file. As we move from one record to another, the record number in the record text 

boxes changes. The navigation control buttons, there are commands to add a new 

record, save a record, delete a record and so on. 

 

                                                  Figure 12.11 
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To add the calendar to the date field in the form, follow the steps given below: 

Step 1. Place the mouse pointer over the Date text box and press Ctrl+Click to select 

it. 

Step 2. Right click and select Control Properties option. 

Step 3. In the Properties: Date Field dialog box, scroll down for Date Forma property. 

By default, Standard (short) format will be displayed. 

Step 4. Click to open the list box and select Standard (long) format. 

Step 5. Scroll down further till you find the DropDown property 

Step 6. Close the dialog box. 

 

 Figure 12.13 

             Figure 12.12 

Forms Control Toolbar 

Step 1. The first step of the wizard is to select fields from the respective tables. 
 
Step 2. Select Event Name field from the list box and click the right arrow (˃) button. 
The field name will appear in the Fields in the Query list box. 
 
Step 3. Clicking on the Next button will display the screen to select the sorting order. 
 
Step 4. The next step is to set the search conditions or the criteria on the basis of 

which records will be filtered from the table. 
 
Step 5. Select field from Fields drop down list, is equal to from Condition. 
 
Step 6. Steps 4, 5 and 6 given in the Steps Pane deal with tasks like summarizing and 
performing numerical calculations 
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                     Figure 12.14                              Figure 12.15 

 

 

  

 Figure 12.16 

Reports 
A report is another useful feature of a database management system. We have seen 

that the records that have been extracted using a query are displayed in a simple row 

and column format. Instead, using a report we can present the retrieved data in an 

attractive and customized manner. We can create a report based on a table or a query 

or both. Preferably, if a report has to be generated from multiple tables, a query 

should be created first and then that query can be used to generate the report. 

Reports: Create a Report 

Let us create a report using the table Events from the Sports Day database. Follow the 

following steps to create a report. 

Step 1. In the Libre Office Base User Interface, click on the Reports icon in the 

Database Pane. 

Step 2. From the Tasks Pane, click Use Wizard to Create Report option. 

Step 3. The Report wizard along with two other windows will be displayed. 
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Step 4. The first step of wizard is to select the table and the corresponding fields that 

we want to display in our report. 

Step 5. All the fields of the Events table will be listed in the Available Fields list box. 

Click >> button to shift all the fields to Fields in report list box. 

 
 

                      Figure 12.17                                        Figure 12.18 

 

Step 6. Click on the Next button. 

Step 7. Click on the Next button. The next step is to group the data based on any of 

the fields in the report. 

Step 8. The fourth step is to set the Sort options. 

Step 9. Click on the Next button to move on to the next step in which the layout of the 

report will be selected. 

Step 10. A layout is the manner in which the labels, field values and titles will be 

displayed in the report. 

Step 11. Click on the Next button to move to last step. 

Step 12. Click on Finish button to display the report. 
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                Figure 12.19                                         Figure 12.20 

 

 

  

                                                  Figure 12.21 

 

 

 

                       Figure 12.22                                               Figure 12.23 
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Reports: Inserting Date and Time 

To insert the date on which the report is generated, follow the following steps. 

Step 1. Click in the Page Header area to make it active.  

Step 2. Click Insert > Date and Time… option 

Step 3. The Date and Time dialog box. 

The date will be inserted on the top left corner of the Page Header area. You may click 

and drag it to reposition it in any place in the Page Header area 

 

 

 

                   Figure 12.24                                                           Figure 12.25 

 

 

             Figure 12.26 
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Summary 

In this session, you have learnt about the form and report. 
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Chapter 13 

 IT Work Environment 

 

Session Objectives 

The students will be able to: 

 Overview of IT work environment. 

 Identify required resources in IT work environment. 

 Explain health related problems and solution. 

 Identify health and safety requirements for computer workplace. 

Introduction 

Information Technology (IT) deals with working on computers, where all manual 

processes can be accomplished by using computer. To accomplish such task, one 

needs to have suitable work environment. There are various parameters taken into 

consideration while working on computer and deciding IT work environment. 

IT work environment 

Almost all IT jobs requires long hours sitting. It is better to keep it restricted to 8 to 10 

hours. Most of the people now use mobile devices. These devices will normally 

interrupt in your work time as well as in personal time. A lot of energy is utilized while 

attempting such devices. So one should keep the mobile devices off during work time. 

While performing any IT job, one has to deal with many people related with it. So it is 

necessary to take care that no major problems will arise while dealing with different 

people. Most of the IT projects are driven by the deadline. A data entry operator is 

under constant pressure to deliver the output within time. The IT workplace must be 

clean and hygienic so that the employee can sustain in the work environment. 

Required resources in IT work environment 

To accomplish any IT task, the following resources are essentially required. 

 A computer machine with appropriate operating system environment. 

 Proper electrical connections with earthing. 

 Internet connectivity – wired or Wi-Fi. 

 Online help or e-books facility for the further reading to develop skills. 
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 Appropriate communication system for communication with clients. 
 

 

Health related problems and solution 

Musculoskeletal Problems 

This problem include different areas of your body such as neck, back, chests, arms 

shoulders and feet. Numbness may happen in the arms and hands. These problems 

may happen because of your posture, while using the computer wrongly. The reasons 

may be uncomfortable chair for sitting or using a workstation that is not 

ergonomically correct for your body. 

  

 

 

 

 

 

                                                   Figure 13.1 

 Position your computer such that the end of them on it or should beat your eye 
level. 

 Keep the neck neutral with monitor directly ahead to prevent to turn your neck. 

 Keep your monitor at least arm length distance, or 20 to 30 inch away from 
you. 

 Maximize contact of your back against the backrest of the chair. 
          Adjust the back of your office chair 100-110 degree recline. A reclined angle  

          Reduces spinal pressure. 

 

Health related problems and solution 
 

   Keyboard and Arms Positions 

 Place keyboard at a slight negative tilt if you are Sitting up right. 

 While typing, keep your hands slightly lower than elbows, with fingers pointing 
downwards at the floor. 

 Minimize any twisting of your wrists from side to side or up and down. 
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 Use a keyboard palm rest as needed only when you are not typing. Do not rest 
your wrists when typing. It leads to wrist strain. 

 Always takes small breaks while working on the computer to stretch your 
muscles, keep your blood flowing, and to rest your eyes. 

          

  

                        Figure 13.2 

Health Related Problems and Solution 

Upper and Lower Back 

When sat in your desk chair, your spine should be in an upright position. Avoid 

slouching down into your chair or leaning forward onto the desk, as this can cause 

strains, aches and pains. Your lower back(lumbar) should be supported by the chair 

or a cushion so that sitting upright doesn‟t feel uncomfortable or unnatural. 

 

 

                                                   Figure 13.3 

     Health related problems and solution 



 

Page | 81  
 

 

 Stand up and walk around every hour, so that you‟re not sat in the same 

position all day. 

 Slowly lean your torso over to one side of the chair and then the other to stretch 

your sides and spine. 

 Stand up and put your hands together, elbows out, then slowly twist to the 

left and then to the right. 

 

 

 

                                Figure 13.4 

 

Health related problems and solution 

Reduce tension by regularly moving your neck and shoulders. 

 Sit up straight and slowly tilt your head down to one shoulder and then to the 
other to stretch your neck. 

 Move your  shoulders around in small circles, first in direction and then the 
other. 

 Slowly bring your chin down to your chest, hold for 3seconds, and then release. 
 

To keep your arms and wrists ache-free: 

 Reach your arm so ut in front of you and draw big circles with your wrists, first 
in one direction and then the other. 

 Stretch your arms out to the side as far as you can and then above your head 
as high as you can to stretch your arms, wrists and back. 

 Interlock your fingers and then push them out in front of you, with palms 
facing out. 
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                   Figure 13.5                                                                    Figure 13.6 

Health related problems and solution 
 
Strain in Legs and Feet 
 
Your desk chair should be positioned so that you can sit comfortably with your feet 
flat on the floor and your lower legs vertical. Use a foot rest underneath your desk if 
you need more support, or if the chair is putting pressure on your thighs. 

To prevent stiff legs, ankles and feet: 

 Rotate you rankles round in circles under the desk, first one way and then the 

other. 

 Stand up and march on the pot for 30 seconds to improve the blood flow in 
your legs. 

 Stand on your tip toes and stretch upwards, a stall as you can ,to release some 
of the tension in your ankles, legs, back, arms and neck. 

Health related problems and solution 

Eye Strain 
 
Computer‟s bright light, glare and flickering images can cause eye strain and visual 
fatigue. When you constantly focus on screen, you forget about blinking your eyes that 
can cause of drying eyes. It is important to look after your eye health. Specifically wear 
anti-glare glasses to work on computer. 
 
To reduce the risks of visual problems: 
 

 Adjust the brightness of computer screen to save your eyes from strain. 

 Reposition the screen to avoid glare from lights or windows. 

 keep a proper vision distance from computer screen and blink your eyes in an 
interval. 

 Wear anti-glare glasses while working in computer. 

 Keep the screen clean and use a desk lamp to make it easier to see. 

 Ensure the screen colors are easy to look at, and that the characters are sharp 
and legible. 

 Look away from the screen into the distance for a few moments to relax. 

  
Health and safety requirements for Computer workplace 
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The minimum health and safety requirements for computers including Desktop 

computers, Laptops, Tablets, Smart phones, Television screens and Video monitors 

are as follows: 

Display Screen (Monitor) 
 

 The characters on the screen should be well-defined and clearly formed, of 
legible size and with adequate spacing between the characters and lines. 

 The image on the screen should be stable, with no flickering or other forms of 
instability. 

 The brightness and the contrast between the characters and the background 
shall be easily adjustable by the user, and also be easily adjustable to ambient 
conditions. 

 The screen should swivel and tilt easily and freely to suit the needs of the  user. 

 It shall be possible to use a separate base for the screen or an adjustable table. 

 The screen must be free of reflective glare and reflections is able to cause 
discomfort to. 

Health and safety requirements for Computer workplace 

Keyboard 
 

 The keyboard should tilt and be separate from the screen. This will allow the 
operator or user to find a comfortable working position and avoid fatigue in the 
arms or hands. 

 The space in front of the keyboard must be sufficient to provide support for the 
hands and arms of the user. 

 The keyboard should have a matt surface to avoid reflective glare. 

 The arrangement of the keyboard and the characteristics of the keys shall be 
such as to facilitate the use of the keyboard. 

 The symbols on the keys must be adequately contrasted and legible from the 
design working position. 

Health and safety requirements for Computer workplace 

Work Surface 
 

 The work desk or work surface should have a sufficiently large, low- reflectance 
surface and allow a flexible arrangement of the screen, keyboard, documents 
and related equipment. 

 The document holder shall be stable and adjustable and shall be positioned so 
as to minimize the need for uncomfortable head and eye movements. 

Work Chair 

 The work chair must be stable and allow the user to move easily and find a 
comfortable position. 

 It should be adjustable in height in both height and tilt 

 The user‟s feet must be placed flat on the floor or a footrest should be used. 

18 
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Health and safety requirements for Computer workplace 

Space Requirements 

 The workstation should be dimensioned and designed so as to provide 
sufficient space for the user to change position and vary movements. 

 The user should have enough desk space for the equipment they use. 

Lighting 

 Any room lighting or task lighting provided shall ensure satisfactory. 

 Lighting conditions. There must be an appropriate contrast between the screen 
and the background environment, taking into account the type of work being 

carried out. 

 Possible disturbing glare and reflections on the screen or other 

 Equipment should be prevented by co-coordinating work place and 

 Workstation layout with the positioning and technical characteristics of the 
artificial light sources.  

 

 

Health and safety requirements for Computer workplace 

    Reflections and Glare  

 Workstations should be designed so that sources of light, such as windows and 

other openings, transparent or translucid walls, and brightly colored fixtures or 

walls cause no direct glare and no distracting reflections on thescreen. 

 Windows shall be fitted with a suitable system of adjustable covering to 

attenuate the daylight that falls on the workstation. 

    Noise 

 Noise emitted by equipment belonging to any workstation shall be taken into 
account when a workstation is being equipped, to ensuring that attention is not 
distracted and speech is not disturbed. 

 Noise cancelling earphones may provide a solution if some noise is unavoidable. 
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Summary 

In this session, you have learnt about the health and safety health and safety 

requirements and requirements for Computer workplace. 
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Chapter 14 

 Workplace Health, Safety and Hazards 

 

 

Session Objectives 

 

The students will be able to: 

 Explain duties and responsibilities of employer and employee for workplace 

safety. 

 Overview of workplace safety hazards. 

 Identify potential sources of hazards in an organization. 

 Explain hazard identification. 

 Discuss hazard control.    

Introduction 

 

Workplace safety refers to the working environment at a company and encompasses 

all factors that impact the safety, health, and well- being of employees. A safe and 

healthy work environment is the basic right of every worker. A hazard is a source of 

potential damage, harm or adverse effect. It can affect something or someone. A 

hazard has the potential to cause illness or injury to people, or damage to property or 

equipment. These hazards include practices or substances that may cause harm. 

 

Duties and responsibilities of Employer and Employee for 

workplace safety 

 

Responsibilities of Employer 
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As employers should ensure a safe and healthy workplace for their employees and 

also for any customers who may visit the workplace. The employers, must: 

 

 design, provide and maintain safe workplaces without risk to health; 

 identify any hazards and take measures to control the risks; 

 develop and implement safe working practices; 

 provide adequate first aid facilities; 

 provide employees with information, instructions, and training set up 

contingency plans to deal with accidents and emergencies including the 

evacuation of the workplace; 

 ensure that ventilation, temperature, lighting, toilet, washing and rest 

 facilities meet the standard of health, safety; 

 ensure that appropriate work equipment is provided and is properly used and 

regularly maintained. 

 

Workplace Safety Hazards 

The most  common  definition  of  hazard  is „a danger or risk‟ that  is associated with 

something. Something can even be considered a hazard if it would be a trigger for 

causing another hazard to become present, which could hurt someone or something in 

the area. 

Physical hazards – It is the most common and a generic term. It is the risks arising 

from the physical work environment – floors, facilities, walls, and ceilings. 

Falling off heights, slipping and tripping – The reasons for falling are attributed to 

faulty scaffolding and ladders, as a result of contact with electricity, and slipping or 

crashing into anything that throws the worker off balance. On the other hand, trips 

and slips happen right on lower levels, particularly the floor, on ramps and any 

uneven surface in the workplace. 

Electrical hazards – There are many reasons why workers get electrocuted or suffer 

from electric shock at work. For the most part, it‟s due to coming in direct contact 

with live wires, or having indirect contact through a conductor. While not all electrical 

accidents lead to death, there are many life-threatening, severe and often permanent 

injuries that could result from it. 
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Fire hazards– Each establishment must comply with housekeeping standards to 

ensure fire safety. Everyone not follows such requirements, and this leads to accidents 

resulting to fire. 

Health hazards – Health refers to the physical well-being of the workers, and this 

includes the condition of their skin, eyes, ears and all other body parts. 

 

 

 

 

   Figure 14.1 

Potential Sources of Hazards in an Organization 

Bright light sources behind the display screen can create contrast problems, making it 

difficult to clearly see your work. Apply the following possible solutions to avoid this. 

Using computers – Hazards while using computers include poor sitting postures or 

excessive duration of sitting in one position. These hazards may result in pain and 

strain. Making the same movement repetitively can also cause muscle fatigue. In 

addition, glare from the computer screen can be harmful to the eyes. Stretching at 

regular intervals or doing some simple yoga in your seat can mitigate such hazards. 

Handling office equipment – Improper handling of office equipment can result in 

injuries. For example, sharp-edged equipment if not handled properly, can cause cuts. 

Staff members should be trained to handle equipment properly. A relevant manual 

should be made available by the administration on handling equipment. 

 

Potential Sources of Hazards in an Organization 
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 Handling objects – Lifting or moving heavy items without proper procedure or 

techniques can be a source of potential hazard. Always follow approved 

procedure and proper posture for lifting or moving objects. 

 Stress at work – In today‟s organizations, you may encounter various stress 

causing hazards. Long working hours can be stressful and so can aggressive 

conflicts or arguments with colleagues. Always look for ways for conflict 

resolution with colleagues. Have some relaxing hobbies for stress against long 

working hours. 

 Working environment – Potential hazards may include poor ventilation, chairs 

and tables of inappropriate height, hard furniture, poor lighting, staff unaware 

of emergency procedures, or poor housekeeping.  

 

Hazard Identification 

Comprehensive hazard identification is the basis for the prevention of human or 

equipment damage or loss and interruption of processes. 

 

The initial hazard identification makes it possible to: 

 Identify pertinent and important hazards in the health care process; 

 Establish appropriate controls; 

 Define objectives for training and information needs; clearly define the 

responsibilities of management, supervisors, and workers; 

 Draft and implement comprehensive work standards practices, including 

emergency procedures. 

 

Hazard Control 

Hazards that have been identified and assessed as priorities require he employer to 

implement adequate control measures. Control measures should follow the hierarchy 

with a strong emphasis on eliminating hazards at the source, whenever possible. 

1) Take all feasible measures to eliminate the hazard, for example, by substituting 
or modifying the process. 

2) If elimination is impractical or remains incomplete, take all feasible measures to 
isolate the hazard, for example, instituting engineering controls such as 
insulating noise. 

3) If it is totally impossible to eliminate or is late the hazard, its likelihood to cause 
injury should be minimized. This effort should include: 
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a. Ensuring that effective control measures are being applied, such as 

installing proper  exhaust ventilation and providing  personal protective  

clothing and equipment that is properly used and maintained, and 

b. monitoring exposure among at-risk worker. 

 

Summary 
 

In this session, you have learnt about the workplace health, safety and hazards. 
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Chapter 15:  

Prevent Accidents and Emergencies 

 

Session Objectives 

The students will be able to: 

 Overview of accidents and emergencies 

 Classify types of accidents 

 Explain handling accidents 

 Demonstrate types of emergencies 

 Explain evacuation 

 Discuss training to employees 

 Explain fire hazards in the workplace 

 Describe fire extinguisher 

 Identify electrical rescue techniques 

 Discuss first aid 

 

Introduction 

 

In an organization, any small accident or unforeseen situation may turn into 

emergencies if not given due attention. In such situation employees, customers, or the 

public can become panic. The emergencies can be natural or man-made and include 

such things. The natural emergencies may include floods, hurricanes/tornados/high 

winds, earthquakes, while the man made emergencies may include fire, toxic gas 

releases, chemical spills, radiological accidents, contagious illness, explosions, 

workplace violence, civil disturbances and riots. Such situations may disrupt or shut 

down your operations, or may cause physical or environmental damage. 

 



 

Page | 92  
 

Accidents and emergencies 

An accident is an unplanned, uncontrolled, or unforeseen event resulting in injury or 

harm to people and damages to goods. For example, a person falling down and getting 

injured or a glassware item that broke upon being knocked over. Emergency is a 

serious or crisis situation that needs immediate attention and action. 

 

Notice and correctly identify accidents and emergencies – You need to be aware of 

what constitutes an emergency and what constitutes an accident in an organization. 

The organization‟s policies and guidelines will be the best guide in this matter. 

Get help promptly and in the most suitable way – Follow the procedure for 

handling a particular type of accident and emergency. Promptly act as per the 

guidelines. Ensure that you provide the required help and support as laid down in the 

policies. 

 

Accidents and emergencies 
 

Follow company policies and procedures for preventing further injury while 

waiting for help to arrive– If someone is injured, do not act as per your impulse or 

gut feeling. Go as per the procedures laid down by your organization‟s policy for 

tackling injuries. You need to stay calm and follow the prescribed procedures. 

 

Act within the limits of your responsibility and authority when accidents and 

emergencies arise – Provide help and support within your authorized limit. Provide 

medical help to the injured only if you are certified to provide the necessary aid. 

Otherwise, wait for the professionals to arrive and give necessary help. 

 

Promptly follow instructions given by senior staff and the emergency services– 

Provide necessary services as described by the organization‟s policy for your role. Also, 

follow the instructions of senior staff who are trained to handle particular situations. 

Work under their supervision when handling accidents and emergencies. 

 

Types of Accidents 
The following are some of commonly occurring accidents in organizations. 

7 
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Trip and fall – Customers or employees can trip on carelessly left loose material and 

fall down, such as tripping on loose wires, goods left on aisles, elevated threshold. 

This type of accident may result in simple bruises to serious fractures. 

Slip and fall – People may lose foothold on the floor and stairs resulting in injuries. 

Slips are mainly due to wet floors. Other causes includes, spilling of liquids or 

throwing of other slip- causing material on floors, such fruit peels. 

Injuries caused due to escalators or elevators (or lifts) – Although such injuries are 

uncommon, they mainly happen to children, ladies, and elderly. Injuries can be 

caused by falling one scalators and getting hurt. 

 

 Figure 15.1 

 

Handling Accidents 

Try to avoid accidents in your organization by finding out all potential 
hazards and eliminating them. If a colleague or customer in the 
organization is not following safety practices and precautions, inform your 
supervisor or any other authorized personnel. 

Attend to the injured person immediately depending on the level and seriousness of 

the injury, see that the injured person receives first aid or medical help at the earliest. 

You can give medical treatment or first aid to the injured person only if you are 

qualified to give such treatments. Let trained authorized people give first aid or 

medical treatment. Inform your supervisor about the accident giving details about the 

probable cause of accident and a description of the injury. 

Assist your supervisor in investigating and finding out the actual cause of the 

accident. After identifying the cause of the accident, help your supervisor to take 

appropriate actions to prevent occurrences of similar accidents in future. 

 

Types of Emergencies 
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It is important to have policies and procedures to tackle the given categories of 

emergencies. You should be aware of at least the basic procedures to handle 

emergencies in your organization. Typically, you should seek answers to the following 

questions to understand the basic emergency procedures in your organization. 

 What is the evacuation plan and procedure to follow in case of an emergency? 

 Who all should you notify within the organization? 

 Which external agencies, such as police or ambulance, you should notify in 

which emergency? 

 What all services and equipment to should down during which emergency? 

 

 

  

 

 

                  Figure 15.2 

Evacuation 

Individual to lead and coordinate your emergency plan and evacuation. A 
clear chain of command and designation of the person in your business 
authorized to order an evacuation or shutdown should be established. 
 

The coordinator should be responsible for the following: 

 Assessing the situation to determine whether an emergency exists that requires 
activation of your emergency procedures. 

 Supervising all efforts, including evacuating personnel. 
 Coordinating outside emergency services, such as medical aid and local fire 

departments, and ensuring that they are available and notified when needed.D 
 Directing the shutdown of plant operations when required. In the event of 

public emergency, local emergency officials may order you to evacuate your 
premises. In some cases, they may instruct you to shut off the water, gas, and 
electricity. he shutdown of 

 

Training to employees 
 

General training for your employees should address the following. 

 

 Individual roles and responsibilities 
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 Threats, hazards, and protective actions 

 Notification, warning, and communication procedures 

 Means for locating family members in an emergency 

 Emergency response procedures 

 Evacuation, shelter, and account ability procedures 

 Location of emergency equipment and how to use it 

 Emergency shut down procedures 

 

Fire Hazards in the Workplace 
 

The first step to fire safety is assessing the existence of fire hazards within your 

workplace. In most facilities, there are three main types of hazards to evaluate: 

electrical hazards, combustible materials, and flammable materials. 

Workplace fires are also commonly caused by improper storage of flammable material 

or combustible dust. Many facilities handle flammable liquids such as solvents and 

paints, or there is a risk of combustible dust from coal, metals, and food products 

such as grain. 

Dust explosions in particular are a dangerous yet often overlooked fire hazard. There 

must be five elements in order for a dust explosion to occur: existence of dust, 

dispersion of dust, oxygen in the air, confinement, and an ignition source. These are 

known as the “Dust Explosion Pentagon.” 

 

Fire Extinguisher 
 

A fire extinguisher is a protection device used to extinguish fires. It is the equipment 

which can be effectively used for controlling fires. 
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                                                   Figure 15.3 

First Aid for Electrical Emergencies-Electrical accidents cause countless injuries. 

Injury be minimized and many lives saved if proper rescue techniques and treatment 

are used. Electrical accidents may occur at anytime or place. Timely response and 

treatment of victims is a major concern. When an electrical accident occurs, due to the 

effect of muscle cramping, a victim is often in capable of moving or releasing the 

electrical conductor. 

 

 

 

 

 

 

 

 Figure 15.4 

 

Electrical Rescue Techniques 

 
Hazards and solutions 

 

 Be alert for hazards, such as heated surfaces and fire. 

 Incase you cannot switch off the power source, take extreme care. 

 Ensure that your hands and feet are dry. 

 Wear protective equipment, such as gloves and shoes. Stand on a clean dry 
surface. 

 Use non-conductive material to remove a victim from the conductor. 
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             Figure 15.5 

 

High voltage rescue 

 Special training is required for rescues if high voltage is present. 

 Protective equipment, such as gloves and shoes must be worn. 
 
 

 

  

               Figure 15.6 

    First Aid 

 A victim may require Cardio-Pulmonary Resuscitation(CPR). Steps to perform in 
CPR are shown in the Figure below. 

 If the victim is breathing and has a heartbeat, give first aid for injuries and treat 
for shock. 

 Ensure the victim gets medical care as soon as possible. 

 Physician attending the victim must have detailed information to properly 
diagnose and care for the victim. 
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                              Figure 15.7                                                               Figure 15.8 

 

Summary 

In this session, you have learnt about the prevent accidents and emergencies. 

 

 


